Maya Redshift deadline shelf empty


#1

Hi guys, thanks for the wonderful software.

My maya 2016 Deadline shelf is always empty. I suspect a conflict with Redshift 3.0. If I try to launch the submitter manually with mel commands, I have to run the command two times for it two work, it gives me this error the 1st time.

I suspect the userSetup.mel faces the same problem, and that’s why it cannot create the shelf. Everything else is running smoothly. This is the code I launch deadline with. Btw, my repository is detected and my client bin as well.

Thank you!

if( startsWith(whatIs DeadlineMayaClient, "Mel procedure found in" ) ){ DeadlineMayaClient(); }else{ warning( "DeadlineMayaClient either has errors or has not been installed." ); }; running deadline command: -getrepositoryfilepath submission/Maya/Main/SubmitMayaToDeadline.mel Running submission script "C:/IM-FX/Config/DeadlineRepository10/submission/Maya/Main/SubmitMayaToDeadline.mel" // Error: $elements = getRedshiftElementsUniquePaths( $currCamera, $currCamera, $currCamera ); // // Error: "C:/IM-FX/Config/DeadlineRepository10/submission/Maya/Main/SubmitMayaToDeadline.mel" line 4463.85: Wrong number of arguments on call to getRedshiftElementsUniquePaths. //

The second time I run this command everything works, all the time.


#2

It got fixed, but I am not sure why… I have re-installed deadline and a newer version of redshift. Now it works great.