Mayabatch: only 2 machines at a time pick up jobs

Hello,

I’ve done a cursory search, but did not find an answer to this.

We have a very small render farm dedicated to Arnold on Maya. There are 7 physical nodes, total. When I kick off a test render from Maya Submission Tool, all looks fine on the Monitor, frames are rendered correctly. However, it seems that only 2 machines at a time are picking up frames, when I am expecting all 7 nodes to pick up frames.

On the Submitter, I’ve set the Machine Limit to 0 (zero), Concurrent Tasks to 1. Because the Machine Limit is set to unlimited, I am expecting that all available nodes would pick up frames at roughly the same time. Again, only 2 machines pick up at any one time, and it seems that the idling machines are waiting for these 2 machines to finish before they pick anything up.

I’m pretty sure the solution is simple, but I don’t really know what it could be!

Help would be appreciated.

Is it a licensing issue? You can use 2 nodes for free…

Hmm, that might be it… I will check our licenses. Thanks for the tip!

facepalm

It’s a license issue! It’s been a while since we needed to use the farm… totally forgot about the license expiration.

I read recently that 10-nodes are now available for free. Just checked the Deadline documentation, and it seems to be the case.

Since we have exactly 10-nodes assigned as Workers, our farm falls under the “free” category (yay). I thought that, perhaps renaming the .lic file in the License Server folder would default Deadline to the 10-free licenses mode, but this doesn’t seem to have worked. I’m still relegated to 2 concurrent machines, instead of the expected 10. Would anyone know how I could activate the 10-node Free Mode? We had once purchased yearly licenses, so the License Server is set up to look for the .lic file (which is now expired). I also tried to remove the “Path to the license” in the LMTOOLS utility, but it doesn’t allow for a blank in that field.

Would anyone know how I could downgrade Deadline to the 10-node Free Mode?

Small studio here, so any bit of cost savings helps.

Hello!

This issue isn’t that the Workers are still looking to the license server and ignoring the free mode for 10 Workers, it’s that you’re running an older version of Deadline where the limit is still 2. We bumped the limit to 10 in 10.1.15.2, so try upgrading Deadline to the latest version.

Steps to upgrade Deadline here!

Privacy | Site terms | Cookie preferences