Modo rendering from Windows to Linuux

Hi All,

Does anyone use Modo in windows and submit to linux machines successfully through Deadline?

I seem to have no end of issues with the ‘server:/share’ path mapping that Modo uses going across OS platforms.

Thanks in advance,
Ant

Just to outline the way I’m submitting my job from a Windows 10 machine…

Open Modo
image
Create a New Project
image
Save Project to network location
image
Save Modo scene into project folder

Create a Sphere
modo_EgWdNdKssw

Shape in view port
modo_QpqJgVjmxr
modo_8Y09TP2GOr
Apply MDD Deformer (attached as mdd in zip here Sphere.zip (49.2 KB) )
modo_lSSP8FSgfC


Go to render tab
modo_tA5xONwKLI
Go to Final Colour Output and choose network location
modo_t0owvJfA10
modo_4ViAXGTnDE
If rendering in the viewport I get the expected image

When submitting with Deadline it fails due to the way Modo creates file paths
modo_1YKbpenRHB

I don’t believe I should have to set the path aliasing, the Foundry sent me this video guide to the path Alias they use
Pixel Fondue Path Alias on YouTube MODO | Path Aliases

There’s no info on exporting MDD’s to standard UNC paths
https://learn.foundry.com/modo/content/help/pages/system_files/export_mdd.html

There is info on path data, although this doesn’t help
https://learn.foundry.com/modo/content/help/pages/preferences/pref_data.html

You can’t set the ‘Path Aliases’ in Modo to something that’s no there, so I can’t put in the linux path on a Windows box, and Deadline isn’t translating it
|602x195.99999999999997

The documentation on Thinkbox site is missing some of the options that are available, so adds to the confusion (Resolve Path Aliases is not documented)
https://docs.thinkboxsoftware.com/products/deadline/10.1/1_User%20Manual/manual/app-modo.html#plug-in-configuration
image

From the tooltip this would suggest to have it enabled


This would change their mapping, ie server:\share\job to the Windows version \server\share\job, which would then be changed to the linux verions /mnt/share/job for rendering

I’m not sure if this is being done out of order, or it fails when the Path Alias is not set.

I’m going round in circles testing this stuff

Still having no joy getting an MDD applied.

Have tried all different ways in the options and recording the options too
image
The X and O relates to these options
image

Tried to do a command line myself but this doesn’t seem to work, there’s a PixelFondue guide here


And the Official (SDK) docs here
https://modosdk.foundry.com/wiki/Headless#Windows
(no linux though?)
I notice when Deadline is rendering Modo it creates and deletes two files,
job0.txt

EXECUTE
!render.animation {*}

and
ack0.txt

SUCCESS

Where does the actual file with the render settings go??

I found this thread on the Foundry page that spans almost 10 years
https://community.foundry.com/discuss/topic/70117/mdd-file-causing-scene-file-not-to-load-on-render-farm-emergency?mode=Post&postID=1196264
It is possible to open the file in the Hex Editor and edit, removing or changing the MDD entries, restoring it with path (should work if file is in same location as .LXO file). I’m not sure if this is done when Deadline submits??

In my continued googling of this problem I found a link to Render Street which also recommends stripping the path, leaving the file name and uploading the MDD in the same folder as the LXO
https://render.uservoice.com/knowledgebase/articles/1838641-using-external-files-mdd-alembic-with-modo

Could Deadline possibly read the file and perform this action? removing the reference and dumping the file in with the file it uses?