Multi-platform OCIO and Maya problem


#1

Hi there,
I’m just implementing an OCIO config for a vfx house and have come across a problem that I’m not sure quite how to resolve.

We set the OCIO environment variable to point to our OCIO config. Maya picks this up fine. Our renderfarm is Linux, our workstations are Windows. I can translate the OCIO path from windows to linux during submission(as a deadline job environment variable), but it appears the Maya scene has the windows ocio path baked in and as a result, it errors on the farm as the linux machines aren’t translating the path to a linux path.

I’ve ensured the maya scenes are .ma to allow deadline to do its path mapping magic but it doesn’t seem to be changing the ocio path either.

This is the error Deadline is reporting on starting up Maya:
STDOUT: Error: Missing OpenColorIO configuration file: Z:/jobs/JOBNAME/config/colour/ocio/win32_config.ocio

Have any of you come across this issue in multi-platform environments?

Is there something obvious I’m missing or a possible workaround I can implement?

Thanks in advance for your help!
Cheers
p.


#2

Are you sure the OpenColorIO path is baked into the Maya scene file? If its ASCII based, if you open a simple Maya scene file once saved, is it present? I thought this ENV VAR was more likely to be present on the Windows OS machine at either machine/user ENV VAR level?

Assuming you are using the “MayaBatch” plugin (and not the “MayaCmd” plugin), then there shouldn’t be any need to save to *.ma (taking up valuable disk space) as path mapping can happen via the “dirmap” option; assuming you have this enabled in the MayaBatch plugin config:
https://docs.thinkboxsoftware.com/products/deadline/10.0/1_User%20Manual/manual/app-maya.html#mayabatch

See: “Path Mapping Mode” setting (and of course it is enabled for path mapping)

If I’ve misunderstood here and thta *.ocio path really is contained within the saved Maya ma scene file, then path mapping (assuming it is enabled) and your repo configured path mappings are correct, then path mapping should be working for you. If that’s the case, then maybe share your path mapping rules you have configured as perhaps you are missing something here, and its not catching on the ‘find’ path: “Z:/jobs/” <- it could be something silly like lower/UPPER case or forward/back slashes?


#3

We recently had a project which used an OCIO config. Same thing for us. Workstations Windows, rendernode Linux.
The ocio config path is showing up in the error log as a windows path, not being remapped correctly.


#4

Did you figure out a workaround? I’m having to have 3 config.ocio’s one for each platform.