AWS Thinkbox Discussion Forums

Multiple Deadline Worker Windows/Instances

So I’m fairly new here, but I’ve emailed AWS support before, but I feel like this is a better place to ask this question and easier to keep track of.

We have a Render PC on a server rack, we’re running Deadline with Nuke as a render software, there are times when we need to send a render off onto this Render PC from another machine via Deadline so it can render it quickly for us so we don’t locally render on our under-powered machines.

Locally rendering on the Render PC works fine when we launch Nuke and render VFX work, but anytime a PC on our worker network contacts deadline there’s a 60% chance it’ll open up multiple versions of Deadline and the max of our 2 Nuke licenses. We only own 2 of these Nuke licenses so it takes up 100% of our workflow when the program we normally use to edit VFX work in is being used up by Deadline for 1 render. Recently we don’t even need to have a PC send a render to the Render PC to have it pull up multiple instances, it’ll just do it on its own when logging in for the day.

The multiple instances also slow down the PC because it triggers to render all of them at once, slowing down the whole machine. So the multiple instances are acting like 1 Deadline instance and when one renders they all queue up and render. The logs only show 1 job being queued up, so there’s not a lot of “multiple job” in the logs. (There’s also the licensing of plugins that our Deadline has been having issues with, but we don’t know if that is something on one of our own license servers so that’s unrelated).

We’ve apparently had this issue before, (before I was hired) and the previous IT reinstalled Windows and updated the repository, that seemed to fix it for a little while but it went back into this same state as described above. We’ve also had a remote desktop view of the Render PC open and was watched to see if it would open a second instance and it never did, (a watched pot never boils).

So we were wondering if anybody here had any suggestions as to what we can try to fix this, I did take a look at the other posts here that are similar in title to what we have, but ultimately I cannot find a similar enough option in my own Deadline software, and going through the .ini files for Monitor.ini, Launcher.ini, Deadline.ini and didn’t find similar settings. We do have super user access but I am not skilled enough to dive into those options without potentially screwing something up.

I can provide logs or screenshots if need be, we’ve been out of our server rendering like normal for almost a year at this point, trying to figure out the multiple instances, and the licensing stuff. So any sort of help would be appreciated.

One thing you can start with as a temp fix before diving into the issue is creating a Limit for the number of licenses you want to allow Nuke to use which sounds to be just 1 in your case.

Once you’ve created that Limit, assign it to Nuke in Plugins.

Doing the above will at least prevent multiple workers from trying to use Nuke.

To the main issue, I would just make sure that your worker or render PC is set to only have 1 worker launch. How are you launching your worker? Are you launching it through Monitor by just selecting launch worker? Also, how many show up currently in the list of workers in Monitor?

1 Like

I have done the first two things now, hopefully that will temporarily fix it.

For the last paragraph, we usually just leave the render PC on all night, and when logging in the next day there will be a new worker window, sometimes multiple new ones. I’m not too sure if that is what is causing a window to pop up, as we have watched it via remote desktop all night and it never did it when we watched it.

To answer the question though, I believe we just select launch worker through the deadline taskbar icon and setup the render that way. We have our decent worker PC’s that are setup with nuke to edit or do VFX work on, but when they’re done they launch the worker and tell our Render PC to take over the heavy lifting so we don’t have to wait a hour to 2 hours for their scene to render locally.

This picture hopefully demonstrates what I mean. I will try to find out more information from our Artists and see if there’s something I missed with launching our worker node/windows just in case.

Ok, so far we’ve reached what appears to be the temporary fix for our issues.

We decided to create a new VM to host our Deadline Repo, and once that was setup properly we made sure to direct the worker to that new Repo, and so far it seems to be working as intended for 3 jobs in a row. We will be testing it further and I’ll make it as solved if it’s 100% working.

Next step after if it doesn’t fix itself is a fresh Windows Installation.

@Jameson_Fuller thanks for updating us here on the issue and progress. Feel free to reach out to Thinkbox Support team if you run into any further issues.

Privacy | Site terms | Cookie preferences