Need step-by-step instructions to use Krakatoa MX for 1st. time


#1

New user here. Newbie alert.

This is my input data:

This is what I have been able to do:

(1) Krakatoa | Create PRT Loader
(2) Click on “Add Files”, select my *.pts file
(3) [I am probably missing a step here]
(4) Bring Krakatoa to FRONT!
(5) Click on the square button in the low right corner [RENDER]

The screen is blank and everything is very fast. I suspect my point cloud is not processed.

Nothing happens. :frowning:

TIA

-Ramon F. Herrera
JFK Numbers


#2

Hi Ramon.

Most likely what’s happening is that the particles are being drawn as black due to no light being in the scene. You can either add a light to the scene that illuminates the particles (please note that only point lights, spot lights, and directional lights are supported by Krakatoa), switching to additive mode, or using emission.


#3

Thanks, Evan: I am now facing a different problem. When I click on [Render] it seems that the system expects a file ending in 4-5 zeros to be present. However, I have no idea how to generate such file. What I am experiencing is simply too fast. I have used several other apps and that point cloud file requires some heavy duty processing. The specific error message is:

Krakatoa Error
particle_file_istream_factory: The input file “C:\blah\blah\MyFileName00000.pts” does not exist.

TIA

-Ramon
JFK Numbers


#4

As explained in our email conversation, Krakatoa PRT Loader was designed mainly for loading point cloud sequences, where the points are different on every frame of the animation (think fluid simulations, particle simulations, etc.). So out of the box it assumes that the file you picked is part of a sequence, esp. if it ends with a number (e.g. 2013 as might be in your case). So it replaces that number with the current scene time, which by default is time 0, so 0000 or 00000 depending on the format of the file name.

To avoid this, you can check the “Load Single Frame Only” option. You will notice that the file name displayed in the PRT Loader will change from a modified #### pattern to the exact file you picked, and that file will be loaded As Is on every frame of the 3ds Max timeline.

Note that Sequoia, our dedicated Point Cloud Meshing tool, completely removed the animation option, so this problem does not exist there. But Krakatoa is a particle animation tool as its core, so it has a lot of things that make little sense when dealing with LiDAR data, but are useful for VFX work…


#5

Since you asked for step-by-step guidance, there are some other things you will need to do before you hit the Render button. Please watch this video I recorded a while ago:


#6

Ok.

Will do. Some extra characters here.


#7

In the mean time, I have downloaded your dataset and loaded it in a PRT Loader.
Since the PTS file does not tell us in advance how many points it contains, loading it always defaults to Every Nth Point, so the whole file has to be read and points skipped according to the Viewport % value.

For that reason, I highly recommend converting the PTS file to PRT first (as shown in the video).
Your PTS file contains Position, Intensity and Color just like the example I showed in the YT video.
In the latest version of Krakatoa, you can simply select the PRT Loader, and in the Krakatoa Render dialog, under the Save Particles rollout, click the >> button between the two channels lists. Select “SET Channels List From Selected PRT Objects” and the right list will be set to Position, Intensity, Color automatically!

Then just save to a new PRT file name.

Remove the PTS from the PRT Loader, and pick the newly saved PRT file. Now you can immediately see that it contains 36,146,772 points, and you can load First N or Every Nth in the viewport for quick previews. While loading 100% is possible, it is rather slow, but 10% with Every Nth is pretty good for interacting with the scene in the viewports.

I then enabled Use Emission and set a Global Channel Override to copy Color into Emission.
The pure render time from PCache for the 36M points was 5 seconds on my laptop, 13.7 seconds including the PRT file loading.