Problem connecting to the remote connection server

Hi, i did set up deadline repository on a my home office computer (Nicaragua). I started the remote connection server. I installed the deadline clients on 2 remote computers (Poland). And after hours and hours of struggle i still can’t figure out why i can’t connect the remote clients to my local repository. I keep getting those errors (attached snapshot). For the sake of troubleshooting i have turned off all firewalls, nothing does it. The clients do not see or manage to connect the RCS. remote_Connection_01b

I’m using certificates with password, all credentials are filled in properly. I’m not too sure if i have to copy locally on each client the certificates in order to access those, but i tried both ways. Nothing.

I’m getting a little desperate and really need to get this sorted out quickly. Any help very much appreciated. Thank you.

The main thing I can see from your screenshot is that you are using the wrong PFX certificate.

The Deadline10Client.pfx is generated during the Repository installation and is used to connect from the RCS to the Database (or from any Client connecting directly to the Database). The default location of the Deadline10Client.pfx is on the other hand under C:\DeadlineDatabase10\certs

You should be using the Deadline10RemoteClient.pfx to access the RCS from the remote clients, using the password provided when creating that certificate during the Deadline Client installation. The default location would be C:\ProgramFiles\Thinkbox\Deadline10\certs\Deadline10RemoteClient.pfx

Don’t worry, you are not the first one to make the mistake.

Also note that it is absolutely mandatory to generate the Deadline10Client.pfx and Deadline10RemoteClient.pfx in two unique directories, because some of the other files they generate (e.g. ca.crt) have the same names, and would overwrite each-other, breaking the whole thing. For that reason, the latest versions of Deadline propose reasonable default paths that reside away from each other so you cannot break them unless you do it on purpose :wink:

1 Like

Thanks for the quick response. I indeed did not know there was two different certificate for the client and remote clients, so it makes sense that it didn’t work. In the meanwhile i reinstalled and skipped all certificates, and also struggled a bit with some port number’s issues for the RCS. Something i noticed and wasn’t sure if it had any influence was that although i was setting 8080 for HTTP RCS connection in the connection servers settings… it wouldn’t take it sometimes. I then checked the Remoteconnectionserver.ini and noticed it was randomely changed each time i start the deadlinercs.exe. I’m not sure it’s re-routing ports automatically or if there is some sort of autoconfiguration going on there, but eventually without the certificate and TLS protocol i managed to connect. So all good til then.

Now my next issue is that i thought Deadline was free for a certain amount of servers. was it 2 or 3? Either way i’m already at 3 workers connected, and i’m getting license errors, and it will build up to 5 tomorrow. So i tried too go buy a few licenses, something like 49$ per worker per year, but there is no way to just buy that directly on line. So i have to wait now to hear from tthe sales department without knowing how long that will take, all that pressure by the current production i’m in. A bit of downer.

Do you know about the costs? We’re using Houdini / Redshift3D with 5 computers (3 worksttation + 2 slaves) with 4 gpus per machine. Any idea the type of costs we’re looking at please?

Thanks a lot again,

Cheers,

A.LicenseIssue

If you’re only rendering on two machines you won’t need a license. But you’ll need to shut down the Worker applications on the workstations and delete the Worker entries in the Monitor. That way the total workers will be less than 3. Do that so you’re able to run the 2 render nodes while Sales gets back to you.

You’ve already got it fixed, but just for the extra info - the port you’re seeing in Remoteconnectionserver.ini is the port the RCS uses to check if there’s already an instance running, basically to prevent you running two identical RCSs at the same time.

The settings you want to worry about are in the deadline.ini which should have the RCS IP address and port listed under ‘ProxyRoot’.

1 Like

thanks again. Yes that deadline.ini had some info that kept the RCS listening for Tls only (4433), i removed that and now the Http connnections (8080) are going through. Cheers.

Now the problem i have is that the Houdini submitter is taking forever (it’s just hanging) when submitting a scene. If i submit to my local repository it works fine. If i submit to the remotte repository in poland… it just hangs. ANy idea how i can fix that?

Still haven’t heard from the sales department.

THanks again.

A.

When you’re using a Monitor connected to the Poland repository, are you able to submit jobs? And how long does that take?

And are you submitting a scene file with your job submission? If you are, try submitting without it as thats a file the submitter has to upload at the time of submission.

It’s hanging (on my local machine) on opening thte Submittter dialog. I don’t even get to the point of chosing the ROP to render and so on cause that window does not show up. On the remote machine, no issue.

Still waiting to hear from the sales department.

Cheers,

A.

Any chance i could buy those licenses online without having to wait so long for someone from the sales department to contatct me. Cause it’s been quite some time already.

If i understand well, it’s free for two servers, but for 5 servers i will need 5 licenses, right?

Cheers,

A.

Is this a legal reseller?

Cheers,

A.

Absolutely legit.

You can find a list of all authorized resellers here, Motion Media as an Established Level reseller:

1 Like

Really appreciative of the support here, you guys are very repsonsive. But man oh man… what a pain to buy a license. Not a single one of your “official resellers” has a link or anything related to Deadline. MotionMedia apparently does not sell unless my “shipping address” is part of their listing… like i want to receive a “cd rom” or something for the install (is it 1998?) Come on… 4 days i’m trtying to get a freaking license. IMPOSSIBLE. I received an email from the AWS tetchnical support asking me what was my problem with purcahsing Deadline… as if i had managed to even find a link to buy that stuff on line and it didn’t work. NO, i can’t even find anyone anywhere that will sale me the darn thing. So i’m sorry for my little outburst here… but this sucks. NOT NORMAL. It is the only piece of softtware i can’t just buy and get a license within 10-15 minutes. I recall deadline with Socrates or was it Macrocad in holand back in 2008 over the same matter… as if i needed a team of sales people to negotiate the plan for my 5 computers set up. Come on, man… it’s 2021. Cheers,

A

Privacy | Site terms | Cookie preferences