PRT Loader CSV


#1

Hi, I’ve got a problem .
I’m Working on mac , c4d Krakatoa. I thought it would be one of a basic thing but i’ve wasted 3 days and nothing happened.
I need to make an animated point cloud of particles. I have some data from Kinect and then processing, about time and position (frame, x, y, z) in one CSV file it’s about 10,000 points per frame, and I also have separated files with frames (every file is named for example 124.csv, 125.csv, 126.csv … - name is a number of a frame and inside has X, Y, Z position.) When i’ve added CSV with “FRAME, X, Y, Z” through PRT Krakatoa i had every point from CSV on the first frame and it doesn’t make a sequence - i don’t know why. I only need make simple animated point cloud from this.

What am I doing wrong? Is it something with my files or importing options?

Below i’ve attached part of my CSV file - this one which makes whole points only on first frame - not animated.

megafileupload.com/rLbK/pos.csv

I need help as soon as possible - Thanks.


#2

I am unable to download the CSV file from the site you posted - both Chrome and Firefox cylce to the same page when I click on the download link, without getting the file. Note that CSV files compress amazingly well, so you should zip it up and attach to this thread, or just email it to me at bobo AT thinkboxsoftware DOT com.

Some thoughts:

  • Krakatoa does not respect a FRAME value from a CSV file to make a sequence, it only supports numbered files where each file contains the X,Y,Z of the respective frame. So picking a file that has all points from all times with a FRAME value will not make a sequence, but load all points from all frames on every frame.

  • You cannot have FRAME, X, Y, Z in a pure CSV file, unless you also define a header in the first line that specifies what the columns are called. If the file only contains comma-separated values without a header line, then you should skip the FRAME info, because we assume the first 3 values to be X, Y, Z in that case. Otherwise, the FRAME might become the X, X will be Y, Y will be Z, and Z will be lost. It might work if the frame is an integer because the CSV reader will figure out the first floating point (column 2) to be the X.
    Here is all you need to know about CSV files and Krakatoa:
    thinkboxsoftware.com/krak-csv-file-format/

  • As long as the “Sequence” checkbox is checked in the PRT Loader, it should load every frame you have in the sequence, as long as you have one file per frame.

  • When you pick a file from a numbered file sequence, its file name is used as the template for loading the rest of the sequence.
    If the file you picked is called particles1.csv, the pattern used will be particles#.csv, and will load all frames even if they are not padded with zeros. However, if you pick frame particles42.csv, the pattern will be particles##.csv, so frames 0 to 9 will not be loaded, but frames from 10 up will work. If you pick frame particles123.csv, all frames from 0 to 99 will not load, only 100 and higher. For that reason, you should pad your frames with leading zeros to the number of digits you expect, usually 4, e.g. particles0001.csv, particles0042.csv, particles 0123.csv etc. However, I don’t expect your problems to be related to that.


#3

thank You! that was so simple :slight_smile: I didn’t try to load them separately… If I will still have some problems i will write for sure :slight_smile: You’re best!


#4

Now i try to use this particles as an emitter in Thinking particles . Does krakatoa can do it? I’m still trying…


#5

It does not do that.
Krakatoa can read particles from TP, but it has no reverse communication to pass data to TP. In fact, none of the Krakatoa Sources objects are technically particle systems. They are more like “point clouds”. Only the 3ds Max version of Krakatoa has some tools to pass data to the native Particle Flow system (for 3ds Max Thinking Particles, PRT loading support was actually implemented by Cebas and not by Thinkbox).
If you have X-Particles, you believe you could save the PRT Loader to RealFlow particle .BIN files and load them in X-Particles.