AWS Thinkbox Discussion Forums

Random By Shape ID not random?


In Max 2014 am instancing geometry on a PRT Loader with Frost (if this is not the latest please let me know. We are on maintenance. Wish there was a webpage that showed the latest version of all your tools, rather than saying “contact sales”)

The docs seem to indicate the Random Shape by ID will combine the ID channel with the seed in order to get a random shape. I am not seeing this. Changing the seed has no effect on the objects that is instanced. (using a list of custom geometry).

As a workaround I used magma flow to add a static INT to the ID channel. Seems to work. This does, however, also change which particles get geometry because I am using Random % by ID. Would be nice to have independent seeds for these two values (and a seed control in the PRT Loader).



Looks like I found the version page:


I was able to reproduce the problem. Walks and quacks like a bug, so I will log it.
Hopefully we can fix it soon. It used to work in the past, so it seems to be a regression…

Thank you for your report!

It looks like “Random Shape by ID” was accidentally connected to the Animation Timing -> Seed control in Frost 1.4. So, if you need a temporary workaround, you could try changing the Animation Timing -> Seed instead. (You’ll need to temporarily change the Animation Timing offset to “Random Offset By ID” to enable the Seed control.)

OK. I will give it a shot.


Privacy | Site terms | Cookie preferences