AWS Thinkbox Discussion Forums

Realflow prt export and Partitioning problem.

Hi all,

I hope someone can help me out with this as it’s driving me insane.

Firstly I would like to say that I am a complete novice when it comes to C4D (I’m a Lightwave User), I have access to C4D through work, and am using the trial to test out Krakatoa with fluid sims from Realflow as it’s the most cost/time effective way of doing things (the speed of Krakatoa is mindblowing).

I would imagine I will have a lot of questions as I have already come up against some issues that I can’t seem to get my head around, but I’ll limit this post to a single question :slight_smile:

I have my fluid sim (exported from Realflow as a prt sequence) imported using the PRT loader, and everything is fine and dandy so far, but I need to be able to partition the particles to add more. I’ve followed (I think) the correct steps to set up Krakatoa to do the partitioning, but when I send the scene(s) (there are 10 partitions) to the render queue and start to render out the particles, I get an error stating that the Velocity channel doesn’t exist.

I have double checked Realflow and the velocity channel is being exported, and when I use the ‘Channel Copy’ Tag and copy the Velocity channel to the Colour channel, it works fine both in the viewport and when rendering, so I am at a loss as to what’s happening.

I’m attaching a screengrab of what I believe to be all the important settings etc. to see if anyone can shed any light on the matter.

Thanks in advance

Hi there! I’m not entirely sure why that error message is appearing. I don’t get that error message when following the same steps you provided. If you can give me a sample file, I could debug what is happening.

However, there is a more important issue here. “Partitioning” will not work the way you are attempting. Partitioning is based on changing the random seed of a live simulation, or, if they part of a dynamics system, it is based on randomizing the initial position and/or velocity of the particles. But a PRT Loader does not have a random seed, nor does not advert particles over time, so even if you randomized the position and/or velocity on the first frame, this would not affect the following frames which are explicitly loaded from disk as absolute positions.

Since you are loading a pre-baked particle sequence from RealFlow, Partitioning does not really work, and it is not expected to.

One alternative is to use the Repopulate feature of Krakatoa MY and distribute a large number of new particles within the influence range of the particles. It tends to give a blurrier, fuller look to the particles:

Thanks for the reply Conrad, I’ll try to sort out a file for you a little later :slight_smile:

I’ve been playing around with the Repopulation feature and have another question.

When I add the repopulation the time it takes to render increases massively (the actual render time is still fast, just a couple of seconds, it’s the ‘preparing’ part which takes a long long time)

I understand that there’s a lot going on with the amount of particles I have (17.5 million imported from realflow), but in My overall render time has gone from approximately 20-30 seconds, up to close to 7 minutes.

This could very well be down to my settings, which I am still playing around with, but I was wondering if this increase was ‘normal’ as in the videos I’ve seen, the repopulation seems a lot faster.


Well, the repopulation feature is very sensitive, wrong values can quickly use up many resources on your machine. So you might want to try harmless settings and walk careful steps from there until you reach the visual goal.

I believe the render time increase can be reduced without sacrifising quality. Repopulation can actually be difficult to get working nicely. I have been meaning to make the controls more user-friendly.

The performance problem is most likely happening because the “Fill Radius” setting is too small.

Try this to set up repopulation:

To begin:
-Start with the default settings
-Increase “Fill Radius” to 80.
-Select “Enable in viewport” so you can see what’s happening.

Probably you won’t see any particles just yet. Next try this:
-Half the “Fill Radius” to 40, then again half to 20, then to 10, etc.
-Keep halving it until you see the basic shape of your object. It will start getting slower as the number gets smaller.

After you have a proper shape, adjust the “subdivisions” until a lot of particles start appearing. Then use “number of particles per subdivision” to increase that count further for the final render.

Privacy | Site terms | Cookie preferences