AWS Thinkbox Discussion Forums

Repopulate Tag Not Working with XP Source

Are there some guidelines I need to follow when using the Repopulate tag with an XP Source? Because it seems like it just works whenever it feels like it, it is very frustrating

The “Enable in Viewport” option in Repopulation only works for the PRT Loader. That may explain why it is acting up for the XP source. As a result, we recommend caching out the particles to a PRT sequence first before using the feature. Then when you turn on the feature, you will see the results immediately in the viewport.

That said, Repopulation will work all Krakatoa source objects, just only at render-time. That limitation makes testing more difficult. It can be a little tricky to set up the first time. This is how I would recommend using it:

  1. Save out your XP particles to a PRT sequence:
    -Select Krakatoa as the renderer.
    -In the renderer settings, go to Krakatoa > Output > Render To, and select “Save Particles to File Sequence”.
    -Then, Krakatoa > Output > Save Particles, select “Submit Saving Job or Partitioning Job”.

  2. Set up Repopulation:
    -Create a PRT Loader, and load that newly saved PRT sequence.
    -Add a Krakatoa “Repopulate Particles” tag to the PRT Loader.

To begin:
-Start with the default settings
-Increase “Fill Radius” to 80.
-Select “Enable in viewport” so you can see what’s happening.

Probably you won’t see any particles just yet. Next try this:
-Half the “Fill Radius” to 40, then again half to 20, then to 10, etc.
-Keep halving it until you see the basic shape of your object. It will start getting slower as the number gets smaller.

After you have a proper shape, adjust the “subdivisions” until a lot of particles start appearing. Then use “number of particles per subdivision” to increase that count further for the final render.

Privacy | Site terms | Cookie preferences