"....requires map channel 1..." help please


Can anyone help me with this error message?

The material: Material #23 requires map channel 1, which is not available

I know what it means, but I can’t solve it since there aren’t map channels in the material node, right?

I have a map with channel 1 assigned to the diffuse. Does it make a difference it is a vRay material?

Thank you!



Can you provide some more details about what your setup is and which object (Stoke Particle Simulator, Stoke Field Simulator, Stoke Field Magma, Genome modifier etc.) throws the error? Either a simple scene, or some screenshots of what you are setting up would be very helpful!

In general, if a Map uses Mapping Channel 1, the underlying data (particles, field, geometry) must provide that channel, otherwise you will get the error. If the Map is assigned via Magma, the TexmapEval operator has an input socket called TextureCoord which corresponds to Mapping Channel 1. If you pass any Float[3] channel or computed value into it to supply the Map with its own UVW coordinates, the message would go away.


I think attaching a stripped down file is probably easier than my long explanation

Thank you for offering to take a look :slight_smile:
imageBlowoff.zip (323 KB)


I am not sure I understand the issue.

For me, the error only shows up in the Stoke log when there are no particles simulated (because there is no TextureCoord channel if there are 0 particles, as there is no place to store the data :slight_smile: ). As soon as I simulated some particles, the message disappeared when moving the time slider. You had correctly checked the TextureCoord to be acquired from the Plane, and both the Plane and the Stoke had the same Material #56 assigned, looking for the mapping channel. Rendering in Krakatoa showed the correct colors from the image, same as the Plane.

If I misunderstood the question, please clarify.

Also a bit unrelated, but in case you decide to use that disabled Magma modifier on the stack, please note that the Position operator should NOT be passed through a ToWorld operator when running on a Stoke. The Stoke Particle Simulator’s particles are already in World Space, and trying to apply ToWorld to them would apply double transforms, producing wrong results if the Stoke icon is not at the world origin… JFYI.


I realize how far I have to go. Well, it is fun!

Thank you for letting me know. That makes sense that the values need to be there in the cache.

As for the magma, I am grabbing all the flows that I can find to learn with and I grabbed one from deko that was intended for a prt loader. It derives color by object proximity. Glad to know that stoke particles are in world space.

Thank you again!