Rhino 6 no longer working with V-Ray?

I’ve tried this at a few places and getting the same result.

A Rhino 6 submission goes through and renders fine but using V-Ray causes it to fail.

On submission workstation and rendernode I can open Rhino/V-Ray and render fine.

If I submit via Deadline it fails to render, watching it on screen it opens the scene, flashes the frame buffer and closes. sometimes there is no image, other times I’ll get a black image (or many black layers)

I’ve tried running the command that Deadline runs and the issue is the same

"C:\Program Files\Rhino 6\System\Rhino.exe" /nosplash /runscript="_SetCurrentRenderPlugin ""V-Ray for Rhino"" -_LoadScript ""C:\ProgramData\Thinkbox\Deadline10\workers\node1\jobsData\12345abc0a00a000000a000\Setup_tempQPIck0\setup.rvb"" _Render Enter -_SaveRenderWindowAs ""Z:\2021_Rhino_Test\rhino_test.png"" -_CloseRenderWindow -_Exit No " "Z:\2021_Rhino_Test\Rhino_Test.3dm"

however, if I remove this part

" -_CloseRenderWindow -_Exit No "

Then the VFB stays open and the scene renders as expected. It feels like it’s closing the VFB to soon. Issue here of course is it doesn’t close Rhino down!

Has anyone come across this issue? I don’t remember this being an issue before with previous versions

I tested this on a fresh repo 10.0.29.0 and 10.1.18.5 and still having the same issue.

switched off and on things like interactivity, follow the mouse, save/lock file, no joy. Changing CPU/CUDA/RTX makes no difference either.

removing the
" -_CloseRenderWindow -_Exit No "
Does render and save (with the output specified in Rhino) but leaves it open

(I have a ticket open for this)

Privacy | Site terms | Cookie preferences