Shadow map width clamping?

It seems to us that set_shadow_map_width( int width ) clamps at 64 on the low end. Can you confirm?

Ideally we’d like to be able to get much lower, like to say 16 or even 8. KMX lets us render shadow maps as small as 1.

There is no clamping. You can set it to 1.0 if you want. I just tested it on a simple scene and it appears to be working as intended.

Is there some way I can reproduce the behavior you are seeing?

Thank you. There was a bug on our side where the value from our slider wasn’t updating correctly.

Privacy | Site terms | Cookie preferences