Shotgun / Shotgrid with Autodesk accounts?

Should this just work?

https://docs.thinkboxsoftware.com/products/deadline/10.1/1_User%20Manual/manual/event-shotgun.html#create-the-api-script-in-shotgun

The docs don’t mention the Autodesk PAT that now need generating

ShotGrid End User Account Setup | ShotGrid | Autodesk Knowledge Network

Once past this hurdle it should work as before? or does it require other options enabling?

Should I now being using the profile login name, or the email associated with the Autodesk account?

I have ‘In Good Standing’ on my Autodesk profile status

pcoip_client_7yiG4HfdHj

Connecting to Shotgun as 'antg@myemail.com'... UNEXPECTED ERROR:
<class 'ValueError'>
Invalid initialization option
---END ERROR INFO---
Clearing Task filters... done!
Connecting to Shotgun as 'antg@myemail.com'... UNEXPECTED ERROR:
<class 'shotgun_api3.shotgun
Preformatted text`.AuthenticationFault'>
Can't authenticate user 'antg@myemail.com'.
---END ERROR INFO---
Clearing Task filters... done!
Connecting to Shotgun as 'antg'... UNEXPECTED ERROR:
<class 'ValueError'>
Invalid initialization option
---END ERROR INFO---
Clearing Task filters... done!

Connection settings are as usual (this worked prior to switch over). I’ve tried username / email / SSL on and off, creating new API script
pcoip_client_nNKixctRan

I’ll plod on with this and see if I can find what I’m doing wrong

Is this a script user or a human user?

Script users work without a change (they do not have a PAT). You only pass their name, so your example seems correct. The key seems a bit short…

Not sure about human users - I think you’d have to pass the PAT when authenticating with shotgun_api3.shogun.

Thanks Mois,

I am a human, although admittedly I haven’t taken a Voight-Kampff or even a Turing test for some time, although I pass Captcha’s OK.

From what I understand the PAT allows Legacy access for the API

I set the API key as per the instructions

I’ve changed the key so that’s correct, I think Deadline crops the length to hide it.

I’m using the antg account when running the Event test
Scripts > Integration > Test Integration

The Deadline docs are dated now as the ‘scripts’ menu is in a different location
Shotgun — Deadline 10.1.20.2 documentation.

The Repo is set-up as direct connect, easy mode, no RCS / Secrets / Certificates, so I’ve not read into this part.

I’m sure I’m over looking something obvious.

Cheers
Ant

It’s exactly the same setup as we have… and it works here.
By the way I see the script is called deadline_integration, not deadline. But that’s probably just your example.

yeah, I have both deadline and deadline_integration (as shown in last screengrab) to check it wasn’t a required variable, and to create a ‘fresh’ key.

I’m running latest 10.1.20.2

Perhaps you could test authentication in a small isolated script. Check how the Shotgun integration does it, and extract just the relevant parts. Could also get more debug information this way.
Another thing I’m wondering, the shotgun_api3 version distributed with Deadline might be old.

You can test scripts in a deadline context by running them with deadline command:

deadlinecommand.exe -ExecuteScript my_login_script.py

This way you could even get the settings and everything from Deadline, to be closer to the actual process.

I have a login python script and that works ok

I’ve tested with my Autodesk account antg@email.com on a new .shotgrid.autodesk.com account and it works, but trying to use it on a legacy .shotgunstudio.com account doesn’t work.

I used the same legacy password setting, and also used the same Personal Authentication Token.

It seems maybe the issue is with the legacy account (shows antg not antg@…com.) or URL

Oh ok, there was something about setting accounts in the autodesk panel and the shotgrid user management. Don’t remember the details, however. You better ask on the ShotGrid forum.

1 Like

Thanks, I’m having a search through the posts there, I wonder if it’s cert based issues?

I’m not in a rush for this as it seems to only affects the older site

(I’ve done the PAT bits)
https://help.autodesk.com/view/SGSUB/ENU/?guid=SG_Migration_mi_migration_account_mi_end_user_account_html#generating-your-personal-access-token

Privacy | Site terms | Cookie preferences