Sketchup Crashed when rendering skp scene with Vray for SketchUp, Please Help!

rendering-or-submission-issue

#1

Hey there:

I want to build a personal rendering farm. When I tested Thinkbox Deadline 10.0 + Sketchup Pro 2017 + VRay for SketchUp 3.60 (vray_adv_36003_sketchup_win.exe), it caused SketchUp to crash. The specific process is as follows:

My ultimate goal is to submit the *.skp file to the Deadline Repository, then the Deadline Repository will assign the rendering task to my own Deadline Slave, Slave will call her own SketchUp for rendering, and finally output the rendering of multiple scenes. Link Me

TEST1: I found that Deadline + SketchUp just rendered multiple images of the same scene, which is not what I want (I am a new SketchUp, not very skilled in SketchUp operations). Until then I found out that VRay for SketchUp has a "Batch Render” mode, can meet my needs very well. So I made TEST2 again;

TEST2: I tested Batch Render directly in the Sketchup software, and output a rendering of multiple scenes to meet my needs.

TEST3: Now I submit the *.skp file to the Deadline Repository, then check the Use VRay, When the Slave opens SketchUp for rendering, SketchUp will crash and test each time Will crash!!! And I tried to install vray_adv_40002_sketchup_win.exe, vray_adv_36003_sketchup_win.exe, vray_adv_34004_sketchup_win.exe all three versions will crash

Deadline Job Report : 2019-09-23 14:10:09: 0: INFO: Process exit code: -3 –> Please refer to the attachment for details.<<Job Reports.log>> Job Reports.log.py (8.4 KB)

I found out that Deadline called a through the Deadline Slave.log message. <<SketchUpDeadline.rb>> , SketchUpDeadline.rb.py (9.9 KB)

I printed some debugging information in this Ruby script.”"<-------------------------sheldon test xxx------------------------->"”, and tried to find out what went wrong.

Finally, I found that the script did not execute when it executed VRayForSketchUp.setOutputPath() on line 44. An error should occur when executing this function.

My system environment is as follows:

Window 10 Education x64

Intel® Core™ i5-8400 CPU @ 2.8GHz

16G RAM

256G SSD + 2T HDD

NVIDIA GeForce GTX 1660 *2


The following software is installed on my system.

Deadline Repository 10.0.6.3 + Deadline Client 10.0.6.3 (Because I am testing, I installed the Repository and Slave on the same host, which is OK.)

3ds Max 2016 + VRay for 3ds max

SketchUp Pro 2017 + VRay for SketchUp 3.60

I hope to get your help and support, this is very important to me, thank you very much…


#2

Hey Sheldon,

I’m going over the logs you’ve got here (nice work on the debugging lines by the by!) and that output path looks a little off to me. Is the final output file named CR MODELO 3D SKP Chare by B8studio.jpgor is CR part of the folder structure? Could be that there’s some issue with it writing to that spot if it doesn’t exist.

Another path you can try is separating Deadline from the equation to make things a bit simpler.

If you check out that log you’ll find a line Full Command: "D:\Program Files\SketchUp\SketchUp 2017\SketchUp.exe" -RubyStartup "C:\Users\Sheldon\AppData\Local\Thinkbox\Deadline10\slave\DESKTOP-6BU8ESA\plugins\5d8861a14b80d62108f0ad6a\SketchUpDeadline.rb" "C:\Users\Sheldon\AppData\Local\Thinkbox\Deadline10\slave\DESKTOP-6BU8ESA\jobsData\5d8861a14b80d62108f0ad6a\CR MODELO 3D SKP Chare by B8studio.skp". That’s the command that Deadline is running to run your render. Try running that yourself to see if it’s Deadline causing problems, or if it’s just Sketchup.

Also just for kicks, try running the render manually as you would without Deadline.

Report back with what you find, hopefully we can get you back in action!
-Justin


#3

Hey jblagden;
I recorded a video and reproduced my question once, which is convenient for you to verify. The video resolution may be a bit low, and the YouTube resolution takes some time.
https://youtu.be/8a02iET4NuM
Thanks again


#4

Hey Sheldon,

Could you attach the error log from Sketchup? It looks like there was a button for more details on that error message window.

-Justin


#5

Hey jblagden:
I packaged the Sketchup error report, but I am sorry, one of the temporary files(F37T53P0.xml*) I could not find.


SketchUpLog-2019-09-29-09_26_29.zip (57.4 KB)


#6

OK, fine.
When the Deadline 10.0.27.2 + Vray 3.6 + SketchUp 2018 are installed, they no longer crash.:anguished: