Submitter installation for Nuke fails

Nuke-submitter-windows-installer gives me this error:

Could not detect the Deadline Repository Directory because there was an error running deadlinecommand.exe from C:\Program Files\Thinkbox\Deadline\bin
Check that the specified Deadline Client bin directory is correct.

To point out that all other submitter like for Maya installs without a single issue.
Had installed older 10.0.16 version, just updated to 10.0.20.2 and same thing happens.
Nuke10.5v7

Any ideas please? Thanks

Hello!

Please check DeadlineRepository10\settings\connection.ini. Make sure that the entries specified for “hostname=” are resolvable by the machine you are trying to run the installer on. To do this ping the ip address and/or hostname in cmd/terminal.

Make sure that the DEADLINE_PATH environment variable is pointed to the Deadline10 bin directory.

DEADLINE_PATH=C:\Program Files\Thinkbox\Deadline10\bin

Try running the following in command prompt to see if it returns info from the DB.

"C:\Program Files\Thinkbox\Deadline10\bin\deadlinecommand.exe" --pool

There is a manual installation, you can find those instructions at…

https://docs.thinkboxsoftware.com/products/deadline/10.0/1_User%20Manual/manual/app-nuke.html#manual-installation

SHouldn’t the directory be Deadline10 instead of Deadline? or this is just illustration?
There is also a registry entry for deadlinecommand, maybe that points to the wrong place?

Yeah, that registry entry is the “DEADLINE_PATH” variable. Often, DLC will die in these installers and they can’t report the issue.

Charles’ request to run it from the command line should help narrow down if that machine is having connectivity problems, but if @mirkoj did install it to “Deadline” instead of “Deadline10” he’ll need to adjust it for his install.

Also, checking the bitrock installer logs will help here as it will outline the issue. What I’ve also seen is that the certificate for DB communication may be on a mapped drive that the administrator does not have access to, but I’m making large assumptions up front here. The log should give us a better error if Charles’ suggestion doesn’t give us anything helpful.

But it is in “Deadline10”, and also every other submitter is working and installing properly, only nuke one has issue and only that one gives error message and points to Deadline. Is it possible that something in nuke submitter is pointintg and looking into Deadline instead of Deadline10 folder?

You are running the installer, so it should not be caused by the submitter itself or custom scripting.

I ran it here, and it installed without errors (tested with 10.0.17.7).

Have you checked the installer log or the “DEADLINE_PATH” variables yet? Details are in my previous post.

Very similar issue for me installing the 3ds Max submitter on a client machine. Installer ran fine on the host computer. Did you ever resolve this?

No resolution yet. Would you be able to get the bitrock logs for me and check the environment variable? Basically just follow the asks from @cmoore and myself.

Are you using the same user account to install the Nuke submitter that you used for installing the Maya submitter?
Or did you have the deadline repository mapped when you ran the other submitter installs and not mapped for this one?

I just had the same error installing the SketchUp submitter and the cause of the issue was that the local admin account I was using didn’t have access to the deadline repository. Mapping the deadline repository temporarily with domain creds allowed the submitter install to touch the repository and finish what it was doing.

1 Like

Also still having the same problem on Windows 10 installing Cinema 4D submitter.

I’m not seeing that answer so i’m gonna drop it here…

Run the installers as administgrator. If just like me the repository is installed on the C: drive Windows will not allow the installer to access the folder unless it is has admin privileges.

Same goes for whatever app you using, Houdini, C4D… if you don’t give admin privilges to that package the submission to deadline will not work. It will tell you again that it can’t find the folder, bla bla bla…

A.

1 Like

For me this works on windows:

Right-click the exe and choose Troubleshoot Compatibility, Try Recommended Settings, Test the program. you should be able to access your Program Files.

I’ve just posted on another thread but I’ve just found this that seems more appropriate.
Same problem here but with cinema4D.
Maya didn’t have any issue.

Did anyone have any luck? I’ve tried what they are suggesting here, ENV var, permission etc etc but nothing worked for me.

Thanks!

m.

Having the same issue with C4D on Windows 10

By the way this path that mirkoj posted is wrong - it should be Deadline10, not Deadline. So it might be a bug in the submitter installation.

Privacy | Site terms | Cookie preferences