"The connection attempt timed out" connecting Win10 client to new Centos7 repo

I’ve been tasked with moving our studio’s small farm from Smedge to Deadline. I volunteered since I’ve done this process a dozen times on my home machines without any issues.
Error message:
“Could not connect to any of the specified Mongo DB servers in the “Hostname” parameter of the “settings\connection.ini” file
poco: The connection attempt timed out.”

#cat connection.ini
[Connection]
AlternatePort=0
Authenticate=False
DatabaseName=Deadline10db
DbType=MongoDB
EnableSSL=True
Hostname=poco
PasswordHash=
Port=27100
ReplicaSetName=
SplitDB=False
Username=
Version=10
StorageAccess=Database
CACertificatePath=

Confirmed samba share: \poco\DeadlineRepository is accessible from client
Confirmed Deadline10db.service is “loaded active running”
SELinux is disabled
Firewall exceptions as per installation guide set
The certificate .pfx file used by the client is located on a shared network folder on a separate file server.

The only thing that I can think of that might have messed things up is the server hostname was changed after the database and repository were installed. I first tried to generate a new certificate using the pyOpenSSl guide, same error. So, I followed the relocation guide as if it were a new machine. Disabled the service, reinstalled, copied new certificate to share. Same result.

I’m not sure what else to try, hopefully someone here has some suggestions?

Check you can ping poco from the machine you’re trying to connect with

it may not have updated, or maybe using poco.local or poco.company.com

you can check this on poco by running ‘hostname’

you can add the IP in the line of connection.ini (replace with your IP)

Hostname=poco;192.168.1.37

I can confirm that the client can ping poco with both the hostname and ip. If i add the ip to the connection.ini hostname field the error message on the client is the same only it now lists both attempts as timed out:

10.9.200.67: The connection attempt timed out.
poco: The Connection attempt timed out.

As a sanity check, i installed the client software on poco and was able to connect to the repository using both the original certificate generated during install and the copy on the shared folder that other machines will use.

The SSL workflow is new to me, so perhaps im missing something in this process. For client machines, you point it to the Deadline10Client.pfx file generated during install. This verifies the identity of the server being connected to, and the password given verifies that the machine connecting to the server is trusted, correct?

yeah, if you can connect to Deadline locally then the same settings can be used on the other machines.

Sounds like something else, network based possibly?

maybe try disabling the firewall both ends and see if it connects

Success! Temporarily disabling firewalld on poco allowed the client to connect to the repository. Boss says its fine to keep it disabled permanently. I may revisit that when I get around to setting up remote access…
The install guide only says to edit iptables, perhaps that isn’t enough for current Centos7 versions?

Thanks anthony for the help.

1 Like
Privacy | Site terms | Cookie preferences