Unable to convert error in assets rollout

Hi I am getting this error in one of my scenes, it worked fine until today and all other scenes work well as well.

Unable to convert: undefined to type: String

deadline 10, corona 3, max 2016

maxscript highlights this row but I haven´t touched anything (also you see greyed out rollouts on the assets menu

thanks for any help

It appears that under certain circumstances a VRayHDRI map’s filename can produce an ‘undefined’ result instead of an empty string, or a valid path.

This was fixed in 10.0.22 where we added an IF statement to check against undefined path:
https://docs.thinkboxsoftware.com/products/deadline/10.0/1_User%20Manual/manual/release-notes.html#id7

  • Jobs with VrayHDRI maps that do not have an output filename defined can now be submitted properly.

The new code looks like

		for aMap in theVRayHDRI do 
		(
			local theFilename = aMap.HDRIMapName
			if theFilename != undefined do
			(
				for aToken in VRayTokens do
				(
					theFilename = substituteString  theFilename aToken[1] aToken[2]
					theFilename = substituteString  theFilename (toLower aToken[1]) aToken[2]
				)
...

It appears that you are running an older version of Deadline. Could you update?

1 Like

thanks a lot update fixed this !

Can you please tell me, why the Error keeps showing up, if I edit the code, by adding this if statement inside or outside of the loop (instead of upgrading the whole repository)? - still showing up the same error - even if the file is edited - only upgrading everything solves the issue.

I cannot answer this without knowing more.

  • Which file exactly are you editing? I assume it is the
    \\DeadlineRepository10\submission\3dsmax\Main\SubmitMaxToDeadline_Functions.ms ? If you are editing the local copy of the script as opposed to the Repository source, it will be obviously overwritten by the unmodified Repository source each time you run SMTD. When the error occurs, the local copy opens in the MAXScript Editor. Editing that will have no effect.

  • What does the error message in the MAXScript Listener look like? Please post it here.

Privacy | Site terms | Cookie preferences