Unable to find Python executable despite path pointing to Python executable


#1

We’ve got a script (quite a few years old) to run through Nuke, though as it requires a license, we were thinking of moving it to Deadline. It needs a path argument, so I tried sending it as a Python script instead of a Nuke script job, so I could use subprocess to call Nuke with the correct arguments.

Python is enabled in the plugin configuration, with the paths to 2.7 set to the default of “C:\Python27\python.exe” and “/usr/bin/python”. On every PC, Python is installed to “C:\Python27”.

However, the jobs all instantly failed with the message Error: Python 2.7 executable was not found in the semicolon separated list "C:\Python27\python.exe;/usr/bin/python". The path to the render executable can be configured from the Plugin Configuration in the Deadline Monitor.

Just curious if you guys know if there’s something simple we’re maybe overlooking here? I can probably edit this particular script to work with the Nuke script submission, but it seems weird that Python is completely not working.


#2

Hi Peter,

take a look at this post, i think i have solved this in a more elegant way.

The problem you run into running a python script that was designed to run in nuke, outside of nuke, is you now have to set python up in the same environment as nuke, that is not the most fun process.
This way we use a nuke type job, that you can then associate with a limit, so the license tracking is there.

Hope this helps.
kym


#3

Hi, thanks for the reply, I wasn’t super clear, but the script I had was designed to run outside of Nuke, with the purpose of launching Nuke with a path to another script (basically the same as the Nuke script job you mentioned, I just wasn’t aware of it before).

It’s probably not too important to fix since it’s recommended that the Python jobs are disabled by default, it’s just strange that Deadline isn’t able to find a Python executable despite it being installed and on the path. IT isn’t ready to make the switch to DL 10 yet so we still gotta make do with 9 for the time being :slight_smile:


#4

Hey Peter,

The other thing you could try is double back slashes or single forward slashes in the paths.
Looking at all our dlinit files i can see we are not ever using single back slashes. might help.

hope that helps.
Kym