AWS Thinkbox Discussion Forums

Unable to modify limits


I’m unable to modify limits from Monitor on following configuration:
Repository: Fresh install of
Monitor: automatically upgraded from

I can create new limits just fine but hitting “Modify Limit Properties…” on the just created limit prints to console with nothing else happening:

2023-09-21 15:28:55:  Traceback (most recent call last):
2023-09-21 15:28:55:    File "C:\thinkbox-conda\conda-bld\deadline_1692834694173\work\DeadlineProject\DeadlineUI\Commands\", line 266, in InnerExecute
2023-09-21 15:28:55:    File "C:\thinkbox-conda\conda-bld\deadline_1692834694173\work\DeadlineProject\DeadlineUI\Forms\", line 786, in __init__
2023-09-21 15:28:55:    File "C:\thinkbox-conda\conda-bld\deadline_1692834694173\work\DeadlineProject\DeadlineUI\Forms\", line 151, in __init__
2023-09-21 15:28:55:    File "C:\thinkbox-conda\conda-bld\deadline_1692834694173\work\DeadlineProject\DeadlineUI\Forms\", line 955, in fillInValues
2023-09-21 15:28:55:  TypeError: setChecked(self, bool): argument 1 has unexpected type 'float'

Is there any know way to solve this and is it possibly related to the upgrading process?


Does this happen on every client’s Monitor? It seems like LimitDialogue script has a ‘float’ type instead of ‘bool’ in an argument.

If it is a one of machine, can you install the client manually?

Okay, I’ve testet:

  • another machine that went through the same upgrade process
  • reinstalling the client ( on my machine.
  • spinning up a fresh Win10 VM and installing the 10.3 client

Same error in all cases.

Edit: Just realised that it only appear in resource limits, not license limits. But I guess that’s to be expected as they_re different dialogues.

hiya! just to confirm another data point on this one. We have 4 sites globally and 3/4 have this issue. the only one that doesn’t is the one we haven’t upgraded yet. that one is still on 10.2

@zainali is it possible to replace that file on the client machine with a known good one from the repo, so that a few of us can configure these limits again?

while not a showstopper this is making it hard to manually keep limits updated.

is there a patch for this? can someone let us know if thats possible and if so what the ETA might be?

Hey all,

I’m not spotting a dev issue to fix this one but it definitely came in with Deadline when we upgraded to a stricter version of Python (we’re on 3.10 now).

I’ll see what we can do for patching this…

1 Like

Hello @dougatbuck

We have an internal ticket to deal with this issue. I cannot share an ETA on when it will be fixed.

What are you changing in the resource limit?
You can modify the existing limit using deadlinecommand as a workaround.

Here is detail

SetLimitGroup <Limit Name> <Limit> <Listed Workers> <Allow List Flag> [<Limit Progress> <Excluded Workers>]
  Modifies or creates the limit.
    Limit Name               The limit name
    Limit                    The new limit - Limit count/ Resource count
    Listed Workers           The listed Workers
    Allow List Flag          true/false
    Limit Progress           Optional. The limit progress. Value between 0.0
                             and 100.0, or -1.0 to disable. (Default to -1)
    Excluded Workers         Optional. The excluded Workers.

deadlinecommand SetLimitGroup blah1 2 <WokerNamesIncluded> false 100.0 <WorkerNamesExcluded>

1 Like

thankyou so much for getting back on this

i think what you shared above will allow us to change the limit count.



Any update on this ticket? We still having the issue on v10.3.0.13.

The fix is merged but not released! It’ll come in when it ships. No promises on a date other than “soon”.

1 Like
Privacy | Site terms | Cookie preferences