V-Ray RTX Standalone Submitter Option

image

Just noticed RTX isn’t an option in the standalone submitter, can this be added? is there a workaround to get it going?

Thanks
Ant

Hi Anthony,

Yes, it can be added.

  • Locate the file \DeadlineRepository10\scripts\Submission\VraySubmission.py and open it for editing.

  • Locate line 61

    renderEngineOptions = ["V-Ray", "V-Ray RT", "V-Ray RT(OpenCL)", "V-Ray RT(CUDA)"]
    
  • Expand it to

    renderEngineOptions = ["V-Ray", "V-Ray RT", "V-Ray RT(OpenCL)", "V-Ray RT(CUDA)", "V-Ray RT(RTX)"]
    
  • Save the file. This will add the option to the Monitor Submitter’s drop-down list.

  • Next, you need to modify the VRay plugin to recognize this option, and match it to a numeric value (7) for RTX according to this documentation: https://docs.chaosgroup.com/display/VNS/V-Ray+Standalone+Command+Line+Options

  • Open the file \DeadlineRepository10\plugins\Vray\Vray.py for editing.

  • Locate line 73 and add the dictionary entry to handle the value, then save the file:

    renderEngines = {"V-Ray" : "0", "V-Ray RT" : "1", u"V-Ray RT(OpenCL)" : "3", u"V-Ray RT(CUDA)" : "5", u"V-Ray RT(RTX)" : "7"}
    
  • Now modify the Vray.options file in the same folder to include the new option string, then save it.

    [VRayEngine]
    Type=enum
    Values=V-Ray;V-Ray RT; V-Ray RT(OpenCL); V-Ray RT(CUDA); V-Ray RT(RTX)
    Label=V-Ray Engine
    Category=V-Ray RT
    CategoryOrder=5
    Index=1
    Description=Select which V-Ray render engine to use.
    Required=false
    DisableIfBlank=false
    

At this point, it should be possible to submit a Job from the Monitor with RTX, and render it with RTX too. I still need to add support to the integrated submitters to do the same (my local install of V-Ray does not have RTX support, I need to update it to see the options and how they are exposed to MAXScript, for example)…

1 Like

Hi Anthony,

Can you please confirm that you tested these changes and they worked as expected?

I don’t have RTX on my local machine, and while I could test it on a g4dn on AWS, I would like to have feedback from an actual user before I commit these into a future Deadline release.

Thanks!

I’ll try to get some testing asap, in the middle of testing this setup atm and for safety I’m going to keep the submissions CUDA based for all apps, I’ll hopefully get some RTX testing on my own setup soon

Thanks again Bobo, appreciate this

I’m not sure it’s picking that up, I just submitted a scene export from 3ds Max 2019.3.4 with V-Ray 43002 with RTX selected, tried submitting an SA job via the monitor with RTX selected but it looks like it goes through as CUDA

2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] Preparing scene for rendering...: done [ 0h  0m  0.1s]
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] Scanning scene for light plugins.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] 4 lights found.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] Using adaptive light evaluation with 8 lights.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] Light tree is enabled with clamp coefficient 0.1 and even split coefficient 0.5.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] CUDA renderer requested.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] CUDA renderer plugin already loaded.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] CUDA renderer plugin instance successfully created.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] EXT_RTOPENCL interface obtained successfully from CUDA renderer plugin instance.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] Using normal thread priority.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] Max ray intensity is enabled: rendered result may have incorrect brightness.
2020-10-15 20:14:59:  0: STDOUT: [2020/Oct/15|20:14:59] [146 MB] ========================

Submission params show

AutocloseVFB=False
CommandLineOptions=
DisplaySRGB=On
DisplayVFB=False
InputFilename=\\servername\DeadlineRepository10\_tests\3ds\renderoutput\3ds_2019_vray43002_interior_00.0266.vrscene
OutputFilename=
RTNoise=0.001
RTSamples=0
RTTimeout=0.0
SeparateFilesPerFrame=True
Threads=0
VRayEngine=V-Ray RT(RTX)

EDIT: It renders so may actually work, the machine I’m using unfortunately has a 1050 so no RTX, where as the node has RTX8000 NVlink, which I guess is another consideration, if using the cards with NVLink I’d image they have to be paired to a Worker to work correctly. Output looks similar on workstation.

I found a problem with my original post, it should have been

Values=V-Ray;V-Ray RT;V-Ray RT(OpenCL);V-Ray RT(CUDA);V-Ray RT(RTX)

There should be NO SPACES between the enum entries, otherwise the control looks wrong. This is because the values then end up including the space, e.g. " V-Ray RT" instead of “V-Ray RT”, and the control does not show up if any of the RT modes were submitted, just the “V-Ray” one works.

I also have a fixed version of the SMTD Workflow to submit with RTX out of 3ds Max. Will post in the other thread…

1 Like
Privacy | Site terms | Cookie preferences