V-Ray Standalone Linux CentOS


#1

In the interest of eventually running standalone Linux jobs on AWS I’ve been running through the process on a local physical machine. After some initial struggles figuring out the correct process to mount the repository directory we use on CentOS I’ve added this testing Linux node to our existing farm but I can’t seem to get it to render a job.

I submit a vrscene via the GUI V-Ray Standalone submitter but receive the following error when the job is picked up:

|2019/07/01 15:09:37|Error|vray-linux|0|Vray|1|[2019/Jul/1|15:09:35] [12 MB] error: Error in file “/home/x/Thinkbox/Deadline10/slave/vray-linux/jobsData/5d1a541ce12d3c084ce67f98/thread0_tempJKxys0/Vanity.vrscene”, line 0: No file “/home/x/Thinkbox/Deadline10/slave/vray-linux/jobsData/5d1a541ce12d3c084ce67f98/thread0_tempJKxys0/Vanity.vrscene” exists|00:00:00:06|15 %|36 %|15 % (8245 / 54966 clocks)|4.258 GB (28%)|4.267 GB (28%)|

If on the local Linux machine I fire up V-Ray standalone this scene renders no problem.

If I navigate to the directory specified in the error there is just a sea of empty Thread0_ folders. It appears there is some issue with the .vrscene file actually being copied to the slave to render. Am I missing an option that helps ensure the .vrscene is passed along? Is this a pathing issue at play? A permissions issue?

Any insight would be appreciated!


#2

Going to reply to my own post…This could be useful to someone else trying to render on some Linux nodes. I’m by no means a Linux expert so some of this is just part of the learning curve associated with CentOs and Linux in general.

I had to mount all of our associated drives for the max files and their related assets. Then needed to add those mount points to the Mapped Paths tools in Deadline with a proper replacement for the paths coming out of Windows. To be explicitly clear for someone else looking at this later, our asset drive path"R:" needs to be replaced with the /mnt/Resources mount point on Linux.