VRay Offload DBR and use local host

Hi

We’re having some issues with DBR rendering. So far, our custom submitter manages to submit the DBR job and starts rendering. However, all buckets rendered by the master are a tad darker than those rendered by the slaves. We’ve set up the DBR options for the 3DsCmd and Max plugins to not use the local host for rendering, and we’ve double checked that the option is turned off in the render scene dialog before submitting the job. But still the master helps with the rendering which results in a faulty render.

Is there a certain flag we have to manually add to the 3DsCmd plugin info file to stop this from happening?

I assume your using Deadline 7.2.0.18? In both the 3dsmax & 3dsCmd plugin configuration, we expose the VRay DBR settings so they can be set globally for all off-load DBR jobs only. So in Monitor -> [super-user] -> Configure Plugins -> 3dsmax/3dsCmd. No flag is needed in the plugin info file as it’s handled at the plugin config level.

docs.thinkboxsoftware.com/produc … figuration

docs.thinkboxsoftware.com/produc … figuration

The options you are referring to were already set as described, but still the master machine helps with the rendering.

ok. could you post the MASTER machine’s slave log report for this job as that should explain why it’s still being used.

See log in attachment.
vraylog.txt (554 KB)

Hi,
Thanks for the VRay log. However, I was looking for the Deadline Slave log here for the MASTER machine (aka the slave that runs the first task (Task ID=0)). You can right-click in Deadline Monitor on the “task 0” (frame 0) in your task list panel when the VRay DBR job is selected and “View Task Reports”.

Oh. Sorry, here it is :slight_smile:
Job_2015-11-17_14-20-50_564b28cad54be811b466a5af.txt (22.2 KB)

As you can see, the log mentions: “13:12:28: 0: INFO: VRay DBR: Use Local Machine: True”.

The question is: why?

Our maxfile doesn’t have the box checked in the vray DBR settings. It’s off in the plugin settings, and I’m submitting the job with the “LocalRendering=false” flag in the plugininfofile.

Am I using the wrong flag, am I missing something else?

Hi,
I’ve replied to the private support ticket that Pieter posted with the patch fix you need, as I think you are both from the same studio?
Something, I don’t understand is how your Deadline Slave log is reporting v7.2.0.18 but the “Use 3dsCmd” plugin option was added only in 7.2.1?

Hi,
I know it is a old topic, but I have exactly this issue. I am running out of ideas and I would really need to find a solution that doesn’t exclude the host machine.

Here is what I got here:

  • All test are done with the same scene/file.
  • The error appears only certain machines.
  • All assets are properly linked and reachable for all machines.
  • In case of error, only the host machine (task 0) render brighter buckets.
  • We have a mix german/english windows, but we all have the same decimal (",") and grouping symbol (".") and the language doesn’t seems to make the difference .

Any ideas what else can it be?

thank you very much,
Alo

BTW, just to clarify:
This only happens when using Deadline Off-Load DBR. Using “manual” distributed rendering (without Deadline), all machines renders fine.

Problem solved, thanks to Karpreet from AWS Thinkbox.

Some machines (the offending ones) were set to use 3dsCmd plugin instead of the 3dsMax plugin. When all of them uses the 3dsMax plugin, there is no more differences with buckets.

Best,
Alo

Privacy | Site terms | Cookie preferences