VRIMG to anything fails


#1

Right now I’m trying to submit vrscene jobs that have Draft jobs appended to them (ie the vrscene/vray standalone renders a vrimg, and then the auto draft job then saves out tiffs/targas/pngs etc of each separate channel). However, no matter how I do it, it will always fail.

I’m currently running 9.0.0.16 (the last released beta before the formal 9 release) and even when submitting a standalone Draft job, the error messages are along the lines of:

2017-03-24 10:42:42: 0: STDOUT: Traceback (most recent call last): 2017-03-24 10:42:42: 0: STDOUT: File "R:\deadline9betarep\events\DraftEventPlugin\DraftQuickSubmission\QuickDraft.py", line 46, in <module> 2017-03-24 10:42:42: 0: STDOUT: path = GetRepositoryPath( "events/DraftEventPlugin/DraftQuickSubmission" ) 2017-03-24 10:42:42: 0: STDOUT: File "R:\deadline9betarep\events\DraftEventPlugin\DraftQuickSubmission\QuickDraft.py", line 34, in GetRepositoryPath 2017-03-24 10:42:42: 0: STDOUT: proc = subprocess.Popen(args, stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE, startupinfo=startupinfo) 2017-03-24 10:42:42: 0: STDOUT: File "C:\Program Files\Thinkbox\Deadline9\bin\lib\subprocess.py", line 710, in __init__ 2017-03-24 10:42:42: 0: STDOUT: errread, errwrite) 2017-03-24 10:42:42: 0: STDOUT: File "C:\Program Files\Thinkbox\Deadline9\bin\lib\subprocess.py", line 958, in _execute_child 2017-03-24 10:42:42: 0: STDOUT: startupinfo) 2017-03-24 10:42:42: 0: STDOUT: WindowsError: [Error 193] %1 is not a valid Win32 application 2017-03-24 10:42:42: 0: INFO: Process exit code: 1 2017-03-24 10:42:42: 0: Done executing plugin command of type 'Render Task'

I know the whole vray standalone/vrscene file stuff is being worked on along with the tile render stuff and the weird parsing issues, but I was at least hoping that I could get this working so we’d have a somewhat straight forward workflow when we need 32/16 bit output.


#2

So if I’m reading things right, it seem that it’s having trouble running DeadlineCommand.

If you go to the machine that threw that error, are you able to do things like open the Monitor (pretty likely) or open an integrated submitter (less likely)? “Not a valid win32 application” makes me think somehow that script is trying to run something it shouldn’t.

Also, so that I can get some better barrings, would you be able to send along the whole log? Maybe just a test scene with box, then archive the job? It’d let me get a leg up on digging into this.


#3

Hey Edwin,

To be honest, this is all stop gap measures for us until the VRSCENE tiling submission and auto-tile job gets squared away. I was just thinking it might be nice to render to a VRIMG file, and then use DRAFT to downsave some 16bit images for us to use, but honestly, I can’t get any of those advanced features to work when submitting a vrscene:

-parsing function gives the [[], '', -1, -1] and The vrscene file does not contain any output file name data and no overrides were set. errors

-tiling functions (as in it renders separate tiles) however none of the assembly functions work because its looking for: 2017-03-30 13:49:53: 0: STDOUT: Unable to read file U:/Tmp/vrimg test\_tile0_METRO MILE TILE.png for tile Tile0 2017-03-30 13:49:53: 0: STDOUT: File does not exist

however, the file is named METRO MILE TILE_tile0_.png

-rendering to a vrimg functions, however, no draft followup functions work and it I can’t even get the automatic vrimg2exr options to work

I know we talked about this a bunch, I’m just anxious because once this issue is solved, I have a bunch of nodes I’m going to license and throw them onto our micro-farm here. Am I the only one who is having these issues? Does vrscene submission work with anyone else?

I think we ran out the clock on our various other tickets, so I’ll open a new one now and send along a bunch of log files with it.


#4

I was discussing this today with on of our pipeline devs, and he mentioned that Max doesn’t populate output information correctly for us.

Which app were you using? I tried via Maya on my side, but it looks like I’m missing a V-Ray license to push things through (will circle back with IT next week).

Could you attach some simple vrscene files so I can take a look here?


#5

FYI. Draft is unable to read/write a Chaos Group *.vrimg image file format.
docs.thinkboxsoftware.com/produc … data-types


#6

Just as a quick update: vrscene files come from sketchup - and I know what your thinking, but its ok, this is the GOOD sketchup/vray (version 3 fixed the vrscene export from SU so that it is in fact universal - as a vrscene file should be)

TBH VRIMG files are not really necessary for me - mostly because we rarely need the bit depth, and they don’t allow tiled renders to take place, which is really what we need and want.

Edwin, I’ll follow up on the support ticket, I think I gave you all the files requested, but if I missed something, definitely let me know!


#7

Thanks man. I’ll try and speed through things today to get at it.