What is the correct way to render LiDAR data through Deadline?


Hi All,

What is the correct way to render particles through Deadline? Rendering particles locally works just fine but when submitting it through Deadline I get the following error messages:

  • Error: 3dsmax: Failed to load max file: “…”
  • Error: RenderTask: Unexpected exception - Failed to open the max renderer

The particle source is a PRT Loader Object which has LiDAR point cloud file attached (the point cloud consists of 44 milion points) and I want to render a camera animation. Could you please tell me what I’m doing wrong? I can’t figure it out.

Thank you very much in advance,

Ser Rick


Normally, submitting a particles rendering job to Deadline uses the exact same process as submitting any other render job. In fact, you could submit to any other render manager (incl. Backburner), and Krakatoa should render the same as any other renderer.

However, you obviously need Krakatoa Render licenses to do that. The Krakatoa Workstation license is only good for interactive rendering inside of 3ds Max. When 3ds Max is switched to network (Slave) mode, it starts looking for a Krakatoa Render license. That license is universal for all non-interactive versions of Krakatoa, so it can be used to render out of 3ds Max, Maya, Cinema 4D, or using the Krakatoa SR (Standalone Renderer).

So the first question I have to ask is - do you own Krakatoa Render licenses?
They are normally sold as part of the Krakatoa MX Standard and Professional Bundles, or can be had individually for $495 a piece. We also sell Krakatoa render Usage Based Licenses on our Marketplace, so if you want to test 50 hours of rendering for $15, you can do that (but you must enable UBL in your Deadline Repository settings)

Unfortunately, I have never tried to run Krakatoa on Deadline without a license, so I am not sure what error one would see if there was no license. If your render licenses are accessible, then the problem could be a bad installation of Krakatoa on your render node. Are you running the Deadline Slave on the same machine where your submitted from, or a different machine? If it is on the same machine, I would expect it to work ok, as long as you have the proper licenses.


Thanks for your elaborate response, bobo.

I feel quite stupid right now, haven’t thought about render licenses at all. We currently have one Krakatoa Workstation license and we don’t have a Krakatoa Render License. I’ve also ran deadline slave locally but that didn’t work unfortunately.


There is an option to force workstation mode in the SMTD. That should use your workstation licenses of Krakatoa, at least to get you started:

docs.thinkboxsoftware.com/produ … ns-rollout


Thanks eamsler, that did the job. I was able to render by forcing work station mode as you mentioned. It is good to know that it’s a license issue :slight_smile: