Can't start New Worker Instance

Hello, as the title suggests I can’t start New Worker Instances either via the Monitor (in Super User mode) nor on the client machine via the Launcher.

Via the Montor the Remote Commands give me a Status: Succeeded, and Results: Connection Accepted.
However when I go to the client machine I get a Worker Startup Error.

Here’s the error message:

Traceback (most recent call last):
File “UI/Forms/MainWindowSlaveStartup.py”, line 178, in Startup
File “UI/Forms/MainWindowSlaveStartup.py”, line 237, in ConnectToRepository
SocketException: Only one usage of each socket address (protocol/network address/port) is normally permitted
at System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(SocketError error, String callerName)
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at FranticX.Net.SocketUtils.CreateTcpListeningSocket(Int32 port, Boolean localOnly, Boolean forceIPv4)
at FranticX.Net.SocketUtils.CreateTcpListeningSocket(Int32 port, Boolean localOnly)
at Deadline.ListenerThread.b()
at Deadline.ListenerThread.Initialize()
at Deadline.Slaves.Slave.b(Int32 adn)
at Deadline.Slaves.Slave.Connect(DataController dataController)
at Deadline.Slaves.SlaveManager.Connect(RepositoryConnectionSettings connectionSettings, Boolean updateScriptManager)
at Deadline.Applications.DeadlineApplicationManager.Connect(Boolean updateScriptManager)
at Deadline.Applications.DeadlineApplicationManager.Connect()

Thanks,

  • Fred

I’m here with Fred and looking into this further and after a lot of digging around, clearing out all settings and uninstall/reinstall on the machine without success, I turned this up: Error when launching two slaves on one node

Could someone at Thinkbox please log a request for the following:

  • Catch this error and warn that if multiple workers are being started on the same machine, this error may have occurred due to the global repository option for “Global Remote Command Port Override” being set? (It would have saved us about a day of time all together now…) Or at least make it clear that this is happening when trying to open the remote command port, which would have helped us guess a connection with this option on our own.
  • When an attempt to add another worker is made, check if this is set and warn that additional workers won’t start as long as it remains set (eg in Remote Control > Worker Commands > Start New Worker Instance…)
  • When setting this (if it’s not done already) warn that this will prevent more than one worker from starting on a machine.

Thanks,
Matt

Privacy | Site terms | Cookie preferences