Cinema 4D R21 subscription license issue with Deadline

I had Deadline working successfully with Redshift and C4D R20, however, my C4D renewal was up so I decided to move to a subscription license for R21. In R21 I am experiencing issues with Deadline, after getting some scripts from Thinkbox about repointing the Cinema4D submission scripts to see R21. I am finding that R21’s new subscription license model is calling the slaves in a different way through the C4DCommandline.exe

In R20 I had a C4D Studio license, I setup Deadline as per the Thinkbox instructions and everything worked across my main machine and my two slaves.

In R21, the deadline submission script correctly makes the call but the R21 C4Dcommandline.exe application is now asking to login to account and is taking down the first license it can get its hands-on, which is the full license, and therefore locking out the other slave and the main c4d machine

I have spoken with Maxon who say that they are bit flummoxed as Redshift apparently doesn’t need the c4dcommandline.exe, but the Deadline submission scripts is calling the respective C4DCommandline.exe for R20 and R21 to perform the render.

Is anyone else having issues with Deadline in R21?

Yeah, I found out while trying to do a silent install that there was a bunch of files you could copy over to do the licensing, will try and dig out which ones when in the office.

There is a pop up if you don’t set this which asks for local, server, sub, rlm license option, wonder if it does this for the CLR

Are you rendering CLR or exporting to RS and rendering standalone?

Still not got my CLR lics so can’t test that side :frowning:

I hadn’t had CLR setup with R20 and deadline just worked, it does look like the R21 new license system will mean I need a CLR :frowning:

Are there any updates on this? Would be amazing to get a fix for R21. Thanks

It’s very hard to get someone from Thinkbox to reply on this forums. I’m having an issue with Deadline and the new C4D licensing model. I’ve been using CLR for several versions but because the licensing model changed for R21 I think something is not working. I get this at the end of the slaves log:

2019-11-15 16:00:01: 0: STDOUT: OpenGL root context initialized
2019-11-15 16:00:01: 0: STDOUT: Vendor : NVIDIA Corporation (NVIDIA)
2019-11-15 16:00:01: 0: STDOUT: Renderer : GeForce RTX 2070 SUPER/PCIe/SSE2
2019-11-15 16:00:01: 0: STDOUT: OpenGL version: 4.6.0 NVIDIA 436.48
2019-11-15 16:00:01: 0: STDOUT: Driver version: 436.48
2019-11-15 16:00:06: 0: STDOUT: Error running authentication: No License Model defined [license_impl.cpp(129)]
2019-11-15 16:00:06: 0: STDOUT: ----
2019-11-15 16:00:06: 0: STDOUT: Enter the license method:
2019-11-15 16:00:06: 0: STDOUT: 1) Maxon Account
2019-11-15 16:00:06: 0: STDOUT: 2) Maxon License Server
2019-11-15 16:00:06: 0: STDOUT: 3) RLM
2019-11-15 16:00:06: 0: STDOUT: Q) Quit

And it stays there… waiting…

If you’ve installed the files on a machine you should be able copy them across and this will (should) stop the activation.

I can’t remember where this was as I can’t get an NFR license for testing from Maxon (they’ve stopped using resellers)

This is annoying now as I’m getting many clients with this issue, so i’ve had to dig out what i did previously

I believe there were 3x files from here
C:\ProgramData\Maxon\License Server\prefs
(They weren’t, I dug this out from somewhere else and they’re local to the user!)

replace ‘user’ with your user and XXXXXXX with your build

“C:\Users\user\AppData\Roaming\MAXON\Maxon Cinema 4D R21_XXXXXXXX\licenseserver.json”
“C:\Users\user\AppData\Roaming\MAXON\Maxon Cinema 4D R21_XXXXXXXX\licensetype.prf”
“C:\Users\user\AppData\Roaming\MAXON\Maxon Cinema 4D R21_XXXXXXXX\offline.license.cinema4d-release”

I can’t test beyond here, interested to see how this works with the linux CLR version!

PS. Use the export to standalone Arnold / Redshift / Octane (10.1 only) and skip the CLR altogether


when you get stuck in getting your Commandline Render app licensed in R21:
You can either do it the manual way by just alling them, or better, follow this articles to automatically use the license servers:
Maxon License server:
Detect Maxon License Server
RLM for Cinema 4D Commandline Render:

I hope this helps.


1 Like

Thanks for these! I’ve linked them in the other thread where some folks weren’t excited about doing the set-up manually.