Monitor startup error - "codec can't encode character"


#1

Hi!

I just installed Deadline10 to test it, but I am having trouble when I try and open it.

image

I am running Windows 10 x64.


#2

Hmm. This looks like an edge case in Unicode handling. Does your username or other system data (hostname, environment variables) use text that is out of ASCII’s tiny 127 character range?

The line the error is referencing seems to be a database connectivity error dialog, so I’d expect the problem to be with the host name of the Repository or Database machine. It’s loading that from the “connection.ini” file of the “[repo]/settings/” folder. You could try removing the actually host name from the “Hostname” line and just use the IP address while we fix this.


Repository installation error
#3

I changed the host name in the repository and left just the IP address, but now throws me an error on a different position. I am attaching the log. Thanks for the help!

2018-09-04 11:56:49: BEGIN - DESKTOP-IV8GQJ2\MH
2018-09-04 11:56:49: Operating System: Windows 10 Pro
2018-09-04 11:56:49: CPU Architecture: x64
2018-09-04 11:56:49: CPUs: 8
2018-09-04 11:56:49: Video Card: NVIDIA GeForce GTX 1060 6GB
2018-09-04 11:56:49: Deadline Monitor 10.0 [v10.0.20.2 Release (12de851eb)]
2018-09-04 11:56:49: Time to initialize: 78.000 ms
2018-09-04 11:56:53: Auto Configuration: No auto configuration for Repository Path could be detected, using local configuration
2018-09-04 11:56:53: WARNING: The database is configured to use SSL/TLS in the Repository connection settings, but no Client Certificate was presented.
2018-09-04 11:56:53: WARNING: Authentication is specified as required in Database Connection Settings file, but no credentials were found.
2018-09-04 11:57:04: Traceback (most recent call last):
2018-09-04 11:57:04: File “UI/Forms/MainWindowStartup.py”, line 156, in Startup
2018-09-04 11:57:04: UnicodeEncodeError: ‘ascii’ codec can’t encode character u’\xe1’ in position 147: ordinal not in range(128)


#4

Hello Miguel,

The new error is saying that the DB requires a certificate, but one is not provided. This is a fairly common mistake since the repo installer has SSL enabled by default, but the client installer does not require or prompt for that. If you look through the client install docs at https://docs.thinkboxsoftware.com/products/deadline/10.0/1_User%20Manual/manual/install-client.html#windows you can see where it asks for the SSL, and gives an example of where the certificates would be on the repo machine. What you would need to do is make those certificates available to the client apps, then refer to them in the change repository dialog. This should resolve the base issue, though I am not sure if you will resolve the unicode issue after those errors. Let us know how that affects things.


#5

Thanks! I just solved it, it was a region problem…I am in Mexico and I changed the region to United States and worked without a problem. Thanks for the support!


#6

Are you running this on AWS? I’m not sure why this would have failed to be honest. Can you provide some details for the next person who experiences this issue?

Also, what was the hostname? I’d like to pass that off to the development team to test out.


#7

Sure, I don’t quite remember well the hostname, I think it was: MHWSMAGICMIKE;192.168.100.173 or maybe another IP that was not mine, maybe that is why it was mixed up looking somewhere else.

I was doing so many things and forgot most of them. I ended up using MHWSMAGICMIKE as host name.

This was my conenction.ini

[Connection]
AlternatePort=0
Authenticate=False
DatabaseName=deadline10db
DbType=MongoDB
EnableSSL=False
Hostname=MHWSMAGICMIKE
PasswordHash=
Port=27100
ReplicaSetName=
SplitDB=False
Username=
Version=10

And yes, I am running this on AWS.

If you need more info, please let me know.

Thanks!


#8

Thanks sir! Now to figure out how to make unicode host names so I can break Deadline Monitor myself… :smiley:


#9

It gives an error when running Monitor.
28


#10

I’ve removed computer name in a “connection.ini” file of the “[repo]/settings/” folder and used IP adress. It gives another sturtup error. As you can see some numbers changed. It looks like a slight progress. What next?
39


#11


#12

Well, ASCII character 128 is outside the range, and it’s erroring on the same line of code so it’s still the host name. Can you delete the whole line and re-type it? I’m guessing the file has text you cannot see within it.

If that doesn’t work, delete the whole file an re-run the installer.