Houdini License Limit - use only Engine licenses on the farm

We have different types of Houdini licenses : FX and Core for artists’ workstations, and Engine for simulation in the farm.

We are trying to limit the houdini jobs to take only the Engine licenses on the farm, so we defined a license limit : there is 4 Engine licenses available, so we’ve set the License Count to 4. Then, we’ve excluded the workstations from this limit in order to use the FX and Core licenses when the worker is running on these machines.

However, some machines on the farm use Core licenses (they are not supposed to use Core), which blocks artists from using their license when working. Are we using the good method to limit machines on the farm to use Engine licenses ?

I’d like to mention that all of our licenses are floating and based on the same licensing server, is it a possible reason that the License Limit is getting bypassed by machines on the farm ?

1 Like

Which version of Houdini are you using?

What is your plugin configuration for Houdini like?

Someone had a similar issue here

found there were entries for ‘escape’ licenses
image

I’m sure I read somewhere there were new licensing options for Houdini 19.0>, I’ll see if I can find that info

Something for the Thinkbox devs to read…

https://www.sidefx.com/docs/houdini/ref/utils/hserver.html#licensingsystem

Add HOUDINI19_CHECKOUT_SYSTEM=1 to the houdini.env file to enable.

The license products are ordered based on a hierarchy. The hierarchy is based on the financial cost and features available for that product (i.e. FX > Core > Engine). The system works based on a list of lists. Each sub list represents a license mode (Commercial, Education, Indie, Non Commercial). The order of the lists also tells hserver which are more important and which are less important (the first sublist being the most important). The order of the sublists are [Commercial, Education, Indie, Non Commercial].

Hython License List

[ [Engine, Core, FX], [Engine EDU, EDU], [Engine Indie, Indie], [Apprentice] ]

We are using Houdini 18.5, but the license server was updated to 19.0 (retro-compatible)

The licensing options with houdini 19.0 could’ve helped, but we are not switching to 19.0 right now

It seems that we can force hython to look for Houdini Engine only with HOUDINI_SCRIPT_LICENSE = hbatch -R in the houdini.env file, it wroks locally, I will check if this works with jobs on the farm.

1 Like
Privacy | Site terms | Cookie preferences